Fix Error: Uw PHP-installatie lijkt de MySQL-extensie te missen die vereist is door WordPress

'Uw PHP-installatie lijkt de MySQL-extensie te missen die vereist is door WordPress'Is een fout die veel eigenaren van blogs en websites tegenkomen WordPress.
Dit is geen reden tot bezorgdheid. Gebrek aan MySQL-extensie from PHP is typisch voor vanaf nul geïnstalleerde besturingssystemen, VPS of dedicated servers, waar PHP-extensies geen deel uitmaakten van het installatiepakket. Dit probleem is bij beide aanwezig Ubuntu en CentOS. In dit scenario wordt het probleem heel eenvoudig opgelost met een PHP-update en module-installatie "php-mysql'.
Update PHP en installeer de MySQL-extensie op Ubuntu

apt-get update
apt-get install php-mysql

Update PHP en installeer de MySQL-extensie op CentOS

yum update
yum install php70w-mysql

Na deze stap herstart Apache-service of NGINX.

Ik kwam ook het scenario tegen waarbij hoewel MySQL-extensie bestaat in PHP, een blog gemaakt op WordPress de foutmelding "Uw PHP-installatie lijkt de MySQL-extensie te missen die vereist is door WordPress". Meestal treedt de fout op bij het installeren van WordPress. Deze keer verscheen hij echter op een blog die al een aantal jaren actief was.
In deze situatie ontdekte ik dat het probleem niet de PHP-modules zijn, maar de zeer oude versie van WordPress, die niet langer compatibel is met PHP 7.4.4RC1. Een eenvoudige WordPress-upgrade naar de nieuwste versie loste de fout op.

Fix Error: Uw PHP-installatie lijkt de MySQL-extensie te missen die vereist is door WordPress

Over de auteur

heimelijkheid

Gepassioneerd door alles wat gadget en IT betekent, schrijf ik graag op stealthsettings.com van 2006 en ontdek ik graag nieuwe dingen over computers en macOS, Linux-besturingssystemen, Windows, iOS en Android.

Laat een bericht achter