FIX PROBLEEM: Uw server draait PHP versie, maar WordPress 5.1.6 3.2.1 5.2.4 vereist minimaal.

Kennisgeving voor iedereen is niet algemeen bekend dat voor installeren of maak upgrade'S Een nieuwere versie van 3.2Het is noodzakelijk dat de worden geïnstalleerd een nieuwere versie van 5.2.4.

Als de server een versie van PHP ouder dan 5.2.4 naar versie te installeren WordPress 3.2.1Verschijnt fout / Message "Uw server draait PHP versie 5.1.6 Vereist WordPress 3.2.1 maar in ieder geval 5.2.4".
Het probleem kan heel eenvoudig worden opgelost door het upgraden van PHP, maar alvorens dit te doen een paar dingen moeten worden overwogen. Ten eerste, upgrade PHP is mogelijk op een shared hosting. Dus u kunt doen de migratie, dient u de beheerder toegang tot de server hebben (Dedicated Server of VPS). In de tweede, moet zijn voordat u de upgrade te documenteren en te beseffen dat nieuwe versie van PHP niet opgegeven fouten andere sites gehost op die server.

Voor is de meest gebruikte besturingssysteem webservers (Agreart en / WHMA) een je laten zien hoe dat te doen upgrade naar PHP op CentOS 5.2.10.x 5 32-bit.

Upgrade PHP op CentOS 5.1.x 5.2.x om 5.x 32-bit

1. Controleren welke pakketten / modules PHP (bijv. php-mcrypt) geïnstalleerd, samen met de standaard pakket. Indien van toepassing, dient te worden geschrapt of actuzlizate.

Controle van geïnstalleerde pakketten:

rpm-qa | grep php

old_php_version

2. Voeg repositories voor Noodzakelijk upgrade'S PHP versie.

nano / etc / yum.repos.d / CentOS-Testing.repo

Het nieuwe bestand (CentOS-Testing.repo) Voegt de volgende code (copy / paste):

[C5-testing]
name = CentOS-Testing 5
baseurl = http://dev.centos.org/centos/ $ releasever / testen / $ basearch /
enabled = 1
gpgcheck = 1
gpgkey = http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X om het bestand te CentOS-Testing.repo op te slaan.

3. Update PHP via yum:

yum update

4. Herstart / httpd :

service httpd restart

Na herstart httpd en controleer de versie van de geïnstalleerde pakketten:

new_php_version

Controleer voor eventuele fouten in modules / pakketten:

php-v

PHP Upgrade / CentOS 32-bit (i386).

FIX PROBLEEM: Uw server draait PHP versie, maar WordPress 5.1.6 3.2.1 5.2.4 vereist minimaal.

Over de auteur

stealth LP

Oprichter en redacteur stealth InstellingenIn 2006 datum.
Ervaring op Linux-besturingssystemen (vooral CentOS), Mac OS X, Windows XP> Windows 10 en WordPress (CMS).

Laat een bericht achter

Deze site gebruikt Akismet om spam te verminderen. Ontdek hoe uw reactiegegevens worden verwerkt.